PRODUCTION - SCT Inst Reception - Incident

Incident Report for Treezor

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 18:42 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2026 - 18:21 CET

Investigating

Dear Customers,

We are currently experiencing a service disruption affecting Incoming SEPA Instant Transfers (SCTR Inst). The issue began at 17:20 CET, and our technical teams are actively working on a resolution.

We will provide further updates as the situation evolves.

We sincerely apologize for any inconvenience caused and appreciate your patience.

Best regards,
Treezor Team
Posted Feb 26, 2026 - 18:00 CET
This incident affected: PRODUCTION ENVIRONMENT (SEPA Credit Transfer - Reception (SCTR) (Production)).