[PRODUCTION] - [PROVIDER] - Digitization Card - Major Outage

Incident Report for Treezor

Resolved

We have monitored all the flows.

The incident has been resolved.

We apologize for the inconvenience.
The Treezor team.
Posted Oct 27, 2025 - 16:11 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 15:45 CET

Identified

Our provider has identified the root cause, and a fix has been implemented.

We will keep you informed of the evolution of this incident.
We apologize for the inconvenience.
The Treezor team.
Posted Oct 27, 2025 - 15:14 CET

Investigating

Dear Customers,

An incident has been detected on the in-App provisioning part of the card digitalization process (Apple and Google).
The end-user is encountering an error and cannot digitalize their card.
We have contacted our provider to find the source of the problem and establish a fix.

We will keep you informed of the evolution of this incident.

We apologize for the inconvenience.
The Treezor team.
Posted Oct 27, 2025 - 12:38 CET
This incident affected: PRODUCTION ENVIRONMENT (CARD - Tokenization Service (Production)).