[PRODUCTION] - [PROVIDER] - SEPA SCTE/SDDE Delay

Incident Report for Treezor

Resolved

We have received confirmation from our provider that all operations have been processed correctly.

Thank you for your patience.
Regards,
Treezor team
Posted Jul 02, 2025 - 18:31 CEST

Monitoring

Dear customer,
Our service provider has informed us of the resolution of this incident.

We have processed all SCTE and SDDE payouts.

We are awaiting confirmation from our service provider that these have been processed correctly.

We apologize for any inconvenience.

We will continue to keep you informed.
Treezor team
Posted Jul 02, 2025 - 15:34 CEST

Investigating

Dear Customer,

Due to an incident at one of our technical partners, SEPA operations will be delayed.
We will keep you informed once our service provider has identified the root cause of the incident.
Please quote MOAI-3090 in any correspondence.

We apologize for any inconvenience this may cause and appreciate your understanding.
Regards,
Treezor team
Posted Jul 02, 2025 - 12:33 CEST
This incident affected: PRODUCTION ENVIRONMENT (SEPA Credit Transfer - Emission (SCTE) (Production), SEPA Direct Debit - Emission (SDDE) - Core (Production)).