Our partner and their cloud provider continue to work on a fix for this issue. We will provide updates as soon as possible.
Posted Feb 19, 2026 - 11:33 CET
Identified
Dear customers,
Our KYC Liveness partner has informed us of an ongoing incident that is currently impacting Liveness identification functionality. Users may experience errors while finishing their identification process.
Our partner and their cloud provider are actively working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and thank you for your understanding.
Best regards. Treezor team
Posted Feb 19, 2026 - 10:05 CET
This incident affected: PRODUCTION ENVIRONMENT (KYC liveness (Production)).