PRODUCTION- Card 3DS Authentication - PROVIDER - INCIDENT

Incident Report for Treezor

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 10:18 CET

Investigating

Dear customers,

Our 3DS Authentication partner is currently facing an incident impacting 3DS authentication functionality.
Users may experience errors during card transactions authentication.

Our partner is actively working to resolve the issue as quickly as possible.
We apologize for any inconvenience this may cause and thank you for your understanding.

Best regards.
Treezor team
Posted Nov 10, 2025 - 12:26 CET
This incident affected: PRODUCTION ENVIRONMENT (CARD - Authorization Processing Service (Production)).