A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 11:57 CEST
Investigating
Dear customers,
Our KYC Liveness partner has informed us of an ongoing incident that is currently impacting Verification process. Users may experience delays in identity verification.
Our partner is actively working to catch up and get back to normal processing as soon as possible. We apologize for any inconvenience this may cause and thank you for your understanding.
Best regards. Treezor team
Posted Jun 25, 2025 - 11:55 CEST
This incident affected: PRODUCTION ENVIRONMENT (KYC liveness (Production)).