[PRODUCTION] - KYC Liveness - Provider - Incident

Incident Report for Treezor

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 11:10 CEST

Monitoring

Dear customers,

Our Liveness verification partner has informed us of an incident that impacted KYC Liveness functionality.
Users may have experienced errors during their identification process.

Our partner has identified the issue and a fix has been implemented.
They are monitoring the results.
We apologize for any inconvenience this may cause and thank you for your understanding.

Best regards.
Treezor team
Posted Oct 02, 2025 - 10:53 CEST
This incident affected: PRODUCTION ENVIRONMENT (KYC liveness (Production)).