[PRODUCTION]- KYC Liveness Partner Disruption
Incident Report for Treezor
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 12:28 CET
Investigating
Dear customers,


We would like to inform you that our liveness partner is currently experiencing disruptions.
Users may experience difficulties finishing their identification process.

We apologize sincerely for any inconvenience and will keep you updated.


Best regards.
Treezor team.
Posted Nov 08, 2024 - 12:22 CET
This incident affected: PRODUCTION ENVIRONMENT (KYC liveness (Production)).