This incident has been resolved. It did not result in any visible impact for end users. All payment services continued to operate normally during this incident.
Thank you for your understanding. Best Regards, Treezor team
Posted Aug 08, 2025 - 15:12 CEST
Investigating
Dear customers,
We are currently experiencing an issue with a central component. Our team is aware of the problem and is actively working to resolve it. We will provide further updates regarding impacts.
We sincerely apologize for any inconvenience this may have caused and thank you for your understanding.
Best regards. Treezor team.
Posted Aug 08, 2025 - 10:12 CEST
This incident affected: PRODUCTION ENVIRONMENT (Other Disruption).