A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2025 - 09:58 CEST
Investigating
Dear customers,
Our Card Processing partner has informed us of an ongoing incident that is currently impacting Card Processing functionality. Users may experience errors, downtime while creating cards, updating card options or digitalisations.
Our partner is actively working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and thank you for your understanding.
Best regards. Treezor team
Posted Sep 15, 2025 - 09:32 CEST
This incident affected: PRODUCTION ENVIRONMENT (CARD - Lifecycle (Production), CARD - Tokenization Service (Production)).