[PRODUCTION]- KYC LIVENESS - PROVIDER - INCIDENT

Incident Report for Treezor

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 10:26 CEST

Investigating

Dear customers,

Our KYC Liveness partner has informed us of an ongoing incident that is currently impacting KYC Liveness functionality since 14:52 UTC.
As a consequence, the SMS feature is temporarily unavailable.

Our partner is actively working to resolve the issue as quickly as possible.
We apologize for any inconvenience this may cause and thank you for your understanding.

Best regards.
Treezor team
Posted May 30, 2025 - 19:02 CEST
This incident affected: PRODUCTION ENVIRONMENT (KYC liveness (Production)).