[PRODUCTION] - Card Acquisition Provider Incident
Incident Report for Treezor
Resolved
Dear partner,

Our card aquiring partner's platform has now been restored.
All their services are accessible since 13:15 CET.

Thank you for your patience.
Treezor team
Posted Apr 29, 2024 - 14:18 CEST
Investigating
Dear Customer,

Our Card Acquiring partner is currently experiencing some instabilities causing payments processing disruptions .
Their teams are actively mobilized to resolve this incident.

We sincerely apologize for any inconvenience and will keep you updated as soon as possible.
Posted Apr 29, 2024 - 10:53 CEST
This incident affected: PRODUCTION ENVIRONMENT (Card acquiring (Production)).