[PRODUCTION] - Card Acquisition Provider Disruption
Incident Report for Treezor
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 13:42 CET
Monitoring
Dear customers,

Our card acquiring operations were recently impacted by an issue that has now been resolved. We are continuing to monitor with our partner.
You may still experience slightly longer processing times as recovery efforts are completed.

We sincerely apologize for any inconvenience this may cause and thank you for your understanding.

Best regards.
Treezor team
Posted Nov 18, 2024 - 10:33 CET
This incident affected: PRODUCTION ENVIRONMENT (Card acquiring (Production)).