Our partner informed us that the incident has been resolved at 02:00 am (CET).
Posted May 20, 2026 - 08:35 CEST
Investigating
Dear customers,
Our SEPA Instant Payment partner has informed us of an ongoing incident currently impacting SCT Inst emission since 10:35 am (CET). Users may experience failures when issuing SCT Inst transfers.
Our partner is actively working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and thank you for your understanding.
Best regards, Treezor Team
Posted May 19, 2026 - 13:24 CEST
This incident affected: PRODUCTION ENVIRONMENT (SEPA Instant Credit Transfer - Emission (SCTE Inst) (Production)).